Guiffy ToolBars

Guiffy has 7 Toolbars and an optional Memory Meter. The Toolbars are displayed based upon View -> Toolbar Options... controls. Each Toolbar's contents are based upon the current operation (File Compare, Folder Compare, or File Merge).

Guiffy Operations ToolBar

opens Open ▼ The Drop Down Open Menu:
open Open & Compare Files...
folder open Open & Compare Folders...
merg Open & Merge Files (2-Way)...
suremerge Open & SureMerge Files (3-Way)...
saves Save ▼ The Drop Down Save Menu:
save html Save Compare Report (HTML)...
save U Diff Save As Unified Diff...
save merged Save Merged File...

Guiffy Edit ToolBar

copy Copies the current selection to the clipboard.
paste Pastes the contents of the clipboard at the insert point (in merge text during a Merge or in the 1st or 2nd text during ComparEdit)
del Mark Marks the selected lines as Removed (displayed with StrikeThru) or reset those lines as Restored.
flip Flip Flips the order of 1st/2nd lines in the current Merge change.

Guiffy Options ToolBar

ignore Ignore Enters the Ignore control dialog for choosing to ignore case, or whitespace differences, or field(s)(in columns A-B and X-Y), or blank lines inserted or deleted, or lines matching Regular Expressions during compares and/or merges.
show Show Enters the Show control dialog for choosing Tab Size, display of entire files(default) or only differences or differences within a context, and displaying line numbers(default) during compares.
tree ignore Folder Ignore Enters the Folder Compare Ignore Options dialog for selecting Ignore these SubFolders, Ignore these Files, Ignore these FileTypes, Ignore Modified Date and Time, Ignore File Size, and Verify files Match(Byte-by-Byte or with Text compare) during Folder Compares.
tree show Folder Show Enters the Folder Compare Show Options dialog for selecting Show SubFolders (Recursively), Show Matching files, Show files Added, Show files Deleted, and Show files changed.

Guiffy Style ToolBar

fonts Enters the Fonts control dialog for selecting different fonts for matching, deleted, and inserted text. The font, its size, italics, and bold can be set for each type of text.
colors Enters the Colors control dialog for selecting different colors for matching, deleted, and inserted text. Background colors are also selectable for each type of text. Plus, foreground and background colors can be setup for selected text.
styles Styles Enters the Style Options dialog for selecting built-in Font and Color options.

Guiffy Navigation ToolBar

choicelist Scrolls the difference view (and merge view while merging) to the difference chosen from its choice list.
choicelist While merging the choice list #prefix indicates changes not merged yet while the ~prefix shows changes already merged.
prev diff Scrolls the difference view (and merge view while merging) to the previous difference.
next diff Changes Scrolls the difference view (and merge view while merging) to the next difference.
prev att While merging, Scrolls the views to the previous Attention(unresolved change).
next att Attentions While merging, Scrolls the views to the next Attention(unresolved change).
auto shift AutoShifts While merging, Guiffy automatically advances to the next Attention. Clicking the AutoShift into [N]eutral will keep the merge on the current Attention after doing a "Keep" --- so you can do any editing needed. Then, click the AutoShifter back into [D] to set Auto Advancing back on and advance to the next Attention. note Ctrl-Click shifts the Auto Advancing into [R]everse - automatically advancing to the previous Attention.
up Up Tree Navigates Up the file tree one level and performs another folder compare.
find Find Enters the Find Tool dialog to search for a string within the differences view. The Find will search the 1st or 2nd text depending upon where the focus is. Focus can be set by clicking in the text viewing area. The Status message at bottom of Guiffy's window will indicate Found, Not Found, or Wrapped.

Guiffy Views ToolBar

recompare Reload Reloads Compare, performs the file or folder compare again.
refresh Refresh Refreshes the view.
vertical Selects the Vertical side-by-side window view of differences.
horizontal Selects the Horizontal split window view of differences.
together Selects the Together single window view of differences.

Guiffy ComparEdit ToolBar

save1 Saves(replaces) the 1st file. Line Numbers(if displayed) and the diff "keys" column are NOT written to the saved file. Lines marked as "removed" and "filler" lines are also NOT written to the saved file.
rep1 Copies the lines of the current change from the 2nd text to the 1st text, replacing the existing lines in the 1st text.
rep2 Copies the lines of the current change from the 1st text to the 2nd text, replacing the existing lines in the 2nd text.
save2 Saves(replaces) the 2nd file. Line Numbers(if displayed) and the diff "keys" column are NOT written to the saved file. Lines marked as "removed" and "filler" lines are also NOT written to the saved file.

Guiffy Memory Meter

memmeter
Displays the Maximum Heap space allowed, Total Memory allocated, and Memory Used. The meter is scaled to the Maximum Heap space allowed - this is set by the -Xmx parameter passed to the JVM (See Tech Note 3: Compare/Merge LARGE files/folders). The Gray bar area shows the Total Memory allocated - this is a high water mark. The memory used is green up to 66%, is orange up tp 84%, and is red over 84%.
seeSee also:
File Menu
Edit Menu
Options Menu
View Menu
Tools Menu
Tech Note 3: Compare/Merge LARGE files/folders


Documentation by Guiffy Software, Inc. 2014