How Do I...

This document covers the primary operations of the Guiffy compare / merge utility.

noteCompare Files

open To Compare Files choose File -> Open & Compare Files. This enters the Open Files Panel for the 1st and 2nd File pair. After selecting the files you want to compare, clickon Compare to perform the Compare. Note: Files can be dragged and dropped on the selection fields in the Open Files Panel. And, you can also drag and drop files onto a file compare view's text area --- this selects the file in the Open Files Panel. Then, either click on Compare, or drag and drop another file onto its field in the Open Files Panel.

note To Cancel a file compare while its running, click on the Cancel button located on the right side of the status bar on the bottom of Guiffy's screen.

noteComparEdit: Edit&Save Compares

Guiffy's ComparEdit features can be handy for when you need to find a change made in one version of a file and include it in the other --- maybe a bug fix. You can Edit and Save either of the FileCompare split view's text. First, find the change you want to copy. Using the logical scrollers prev diff next diff locate the change. Or, locate the change by browsing or scrolling through the views and when you find the change, just click once anywhere on the text within the change. This automatically sets the current change block. Then, click on one of the Replace buttons, either rep1 or rep2 , to copy the change into the the text of the file you intend to update. Then, if thats all the changes you need to make, click on one of the Save buttons, either save1 or save2 , to replace the file.

If you need to replace several change blocks, just keep repeating the locate and replace steps above. You can also make all sorts of other editing changes. To remove lines, Select the lines and then click on the Mark as Removed button. del
Note Once a line has been removed, it will be displayed with a strikethru and look like this:
strike
These lines are NOT written to the Saved file. To restore removed lines, select the line(s), and click on Mark as removed/restored.

To insert lines, place the cursor at the insert point and hit Enter. ComparEdit automatically prefixes the text for the view and adds a "filler" space in other views to keep the scrolling synchronized.

note On an Edit/Paste operation ComparEdit also adds the prefixes and "filler" spaces.

In ComparEdit views a rightclick will produce a PopUp Menu with choices for Save 1st/2nd and Edit operations.
popup

noteMerge Files

To do a simple 2-way merge, choose Merge -> Open & Merge Files(2-Way)...
merge OR, After comparing two files, choose Merge -> Merge Files. This enters Merge mode - A third window (the merge view) will appear above the compare view with a row of buttons below it for interactively choosing the merge content. Merge mode will position the Merge and Compare views at each change. Choose the merge content by pressing one of the 3 selection buttons.
keep
After choosing the merge content for each change, Save the Merged File(Merge ->Save Merge File).

note To Cancel a file merge while its running, click on the Cancel button located on the right side of the status bar on the bottom of Guiffy's screen.

note You can begin your merge based upon keeping the contents of the first, second, or Both files. Or, to start over again, you can Undo All your keep selections. These operations are selected in Tools -> Keep/Undo All...

autoshift While merging, Guiffy automatically advances to the next Attention. Clicking the AutoShift into [N]eutral will keep the merge on the current Attention after doing a "Keep" --- so you can do any editing needed. Then, click the AutoShifter back into [D] to set Auto Advancing back on and advance to the next Attention.

suremerge To do a smart 3-way merge, choose Merge -> Open & SureMerge Files(3-Way)...
OR, After comparing two files, choose Merge -> SureMerge Files. The File Open Dialog will appear to specify the parent file of the two files being merged. After you click on the SureMerge button in the Open dialog, Guiffy will perform a smart 3-way SureMerge ,automatically choosing the merge content for all the changes except those that require your attention, and then enter the interactive merge mode for your resolution of those changes.

note If you make a mistake and keep the wrong file's content for a change, just go back to that change using either the choice list choicedif or Next/Previous Difference logical scrollers prevdif nextdif . The Merge button row will indicate the change has already been merged and looks like this:
undo
Clickon the Undo button and then reselect the change contents for the merge.

note The current merge block always has the little "spotlite" on it that looks like this:
spot
Using the scollbar you can position the merge view away from the current merge block - But, the merge operation is always performed on the current block(and the spotlite sticks to it). To set the current merge block to the change block in your view, just click once anywhere in the text of the change.

note To view the contents of the Parent file for the current merge block, just double-click inside the merge block --- another window will open with the parent file's content. If needed you can select, edit and copy text from the parent view into the merge result text.

noteMergEdit: Edit&Save Merges

Sometimes, while merging a change you want to Keep Both --- But, reverse their order(with the changes from 2nd before those from 1st). Thats exactly what the special MergEdit Flip button flip does.

Once a change has been merged, the changes NOT kept are displayed with a strikethru in each line that look like this:
strike
These lines are NOT written to the Saved merge file.

You can make all sorts of editing changes in the merge view. To remove lines use the Mark as Removed like during ComparEdits. The Removed lines will appear like the merge changes Not kept shown above. Inserting and pasting lines also work like during ComparEdits AND MergeEdit will keep the compare views filled/synchronized.

note The merge file can be Saved before you resolve all the changes. The unresolved changes will have lines wrapped around them in the saved file that look like this:
<<<<<<< C:\com\guiffy\guiffy\jiffy.dos
     if( Curr_Firs < (50-1) ) {
=======
     if( Curr_Firs < (CURMAX-1) ) {
>>>>>>> C:\com\guiffy\guiffy\jiffy.tre
NOTE: Later, you can Open the Saved Merge file and finish your merge.

noteCompare Folders

filetree To Compare Folders choose File -> Open & Compare Folders. This enters the Open Folders Panel for the 1st and 2nd Folder pair. After selecting the folders you want to compare, clickon Compare to perform the Compare. Note: Folders can be dragged and dropped on the selection fields in the Open Folders Panel.

Archive files can also be compared as folders. When Archive is selected the Browse dialog provides for selection of archive files (.zip .jar .ear .war .tar .tgz .gz .tbz2 .bz2).

note To Cancel a folder compare while its running, click on the Cancel button located on the right side of the status bar on the bottom of Guiffy's screen.

To filter the files compared and/or displayed in the Folder Compare use the Folder Compare tree ignore Ignore and tree show Show options. By default, Folder Compare is configured to quickly compare the folder structure, comparing file names, file sizes, and the file modified dates. To configure Folder Compare to verify files match (by applying all the file compare options), set the Folder Compare Ignore Options to: Ignore Modified Date and Time, Ignore File Size, and Verify Files Match with Text compare selected.

The Folder Compare views support Unicode folder and file names. To properly display Unicode folder and file names, select a Unicode font for All Text in the Font Options. The Unicode file will also be used in all file/folder open/save dialogs.

note To Compare Trees - Folders and SubFolders(Recursively), select the Folder Compare Show Options "Show SubFolders (Recursively)". To "Explore" FileTrees and view subfolder compares, clickon [+] to expand and [-] to collapse.

note When comparing folders, not(Recursively), to see if the contents of SubFolders match, select the Folder Compare Ignore Options "Verify SubFolders Match". To "Explore" FileTrees and view subfolder compares, clickon [+] to expand and [-] to collapse.

note To include the Size and Modified details in the FileTree view, select the Folder Compare Show Options "Show Details".

note A Double LeftClick on a file in the FolderCompare Tree View performs a File Compare and opens another window for viewing the file compare. If the other file is missing, the compare will be performed with an "empty substitute".

note A Double LeftClick on a folder in the FolderCompare Tree View performs a Folder Compare (replacing the current folder compare view). If the other folder is missing, the compare will be performed with an "empty substitute". up Will navigate back up the Tree View.

noteSynchronize Folders

Synchronizing Folders includes operations such as copying or deleting files and/or sub-folders from one file tree to another. After these operations, some files may need to be merged - see the How to Merge Files above. To synchronize folders, after comparing the folders(in the Split Tree Views), select a file or folder - then, a rightclick will produce a PopUp Menu with choices for Compare, Merge(2-way), SureMerge(3-way), Copy, Delete, Rename, SaveAs, and Select All operations. The compare views are dynamically updated following copy or delete operations.
popup
note For Mac users, a mouse right-click is simulated by Control-click.

The Copy and Delete operations support multiple selections. Mulitiple files and/or folders can be selected via the PopUp Menu's Select functions or by using your mouse. The multiple selections do not have to be contiguous. Hold down the ctrl key and click to add the node to the current selection. Hold down the shift key to add a range of nodes.
note For Mac users, to add the node to the current selection, hold down the command key and click.

seeSee also:

Toolbar
File Menu
Merge Menu
Controlling Compare
Choosing View Attributes
Selecting Compare Views


Documentation by Guiffy Software, Inc. 2014